Why can't I add a dependency to my UI in my class library?